Cercare testo contenuto in una cella di un foglio Excel

Condividi questo Post

In questo articolo vediamo come cercare testo contenuto in una cella di un foglio Excel.

Cercare se nelle celle esiste un testo uguale

Per cercare se nelle celle esiste un testo uguale basta usare la formula:

=SE("ciao"=E2;"ok";"no")

Molto semplicemente se la cella E2 contiene la stringa “ciao” nella cella dove abbiamo scritto la formula apparirà “ok”, altrimenti apparirà “no”.


Cercare se nelle celle è contenuto il testo cercato

Per controllare se nelle celle è contenuto del testo l’operazione non è così immediata.
Bisogna utilizzare la seguente formula:

=SE(
    VAL.ERRORE(
        TROVA("TestoDaCercare"; CellaDoveCercare)
               );
    "ValoreSeNonTrovo"; "ValoreSeTrovo")

quindi:

=SE(VAL.ERRORE(TROVA("Oscar";B1));"NO";"SI")
Cercare testo contenuto in una cella di un foglio Excel


La ricerca funziona e dà risultato positivo sia se il nome è inserito all’inizio, alla fine o al centro di una cella.
La ricerca è case sensitive, quindi è sensibile alle maiuscole o minuscole. Come nel caso dell’ultima riga dell’immagine d’esempio: “Oscar” è diverso da “oscar”.


File Excel d’esempio

Click sul pulsante scarica per effettuare il download del file contenete le regole spiegate in questo articolo.
In questo file è possibile cercare testo contenuto in una cella di un foglio Excel.


Rispondi

Subscribe To Our Newsletter

Get updates and learn from the best

Esplora Altro

Modificare la dimensione della barra di Windows11
microsoft

Modificare la dimensione della barra di Windows11

Modificare la dimensione della barra di Windows11 non è un’opzione supportata dall’interfaccia utente, ma comunque possibile. Questo quesito mi è stato sottoposto da operatori in

Power BI dashboard
Dev

Power BI dashboard

Power BI dashboard: permette la reazione di grafici, tabelle e dashboard prelevando dati da diverse origini: Database, file, elenchi SharePoint, Dynamics NAV, etc… Possibilità di

microsoft

Exchange Online Autenticazione SMTP

Exchange Online Autenticazione SMTP, abilitare i client con TLS legacy. Con l’innalzamento della protezione da parte di Microsoft dei server SMTP del servizio Microsoft365, da

Do You Want To Boost Your Business?

drop us a line and keep in touch

small_c_popupAP

Facciamo 2 chiacchiere

Chiedi le informazioni di cui hai bisogno

%d blogger hanno fatto clic su Mi Piace per questo: